Seltsamer Java-Fehler

Ich arbeite schon längere Zeit mit ein und dem selben Rechner, mit ein und der gleichen Eclipse-IDE-Version, mit ein und der selben JDK-Version.

Ich hab nichts angefasst und trotzdem … Aus dem heiteren Blau heraus, bekam ich folgende Fehlermeldung:

Java.lang.VerifyError: Expecting a stackmap frame at branch target

Sehr seltsam … Das hat wieder eine Stunde meiner Lebenszeit verschwendet, bis ich herausgefunden habe, dass man in den JRE-Settings in Eclipse als Standardparameter folgendes angeben muss:

-XX:-UseSplitVerifier

Wieso warum und weshalb jetzt pötzlich überhaupt?

Keine Ahnung!!!

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s